AcadGRAC

Navigation: »No topics above this level«

AcadGRAC (dodatak za AutoCAD)

 Return to chapter overview

Autor programa je: Tihomir Bojanić, dipl.ing.geodezije sa 20 godišnjim iskustvom kao izvršilac i rukovodilac na geodetskim poslovima u rudarstvu (Rudnik bakra Majdanpek) i 11 godišnjim iskustvom u urbanizmu na izradi urbanističkih i prostornih planova u AutoCAD-u (JP Urbanizam Novi Sad)

telefon: | 063-476-438 ili 021-55-33-94
Mail: | tikab@nadlanu.com
Site: | http://www.tika.rs

Program se može slobodno preuzimati za sada samo od Autora a kasnije i sa određenih Sajtova ali se može koristiti isključivo uz USB Hard Lock koji se može nabaviti samo od Autora.


Uvod

Navigation: »No topics above this level«

Uvod

 Return to chapter overview

AcadGRAC je dodatak za AutoCAD za sve verzije od R14 do trenutno 2010 a i buduće.

Namenjen je prvenstveno geodetskim i ostalim stručnjacima, da svoje terenske podatke merenja na jednostavan način uvedu u AutoCAD okruženje i uz pomoć klasičnih i ciljano kreiranih novih komandi, na što jednostavniji način dođu do željenog crteža.

AcadGRAC je, kao logičan nastavak DOS programskog paketa GRAC, istog autora, koji se i posle 15 godina, aktivno koristi u primarnoj obradi geodetskih podataka, preuzeo sve pozitivne osobine svog predhodnuka, ovaj put oslonjen na moćno okruženje AudoCAD-a.

Tekstualni format zapisivanja geodetskih podataka, je kompatabilan sa svojim predhodnikom.

Za sva štampanja geodetskih podataka formiraju se Excel dokumenati na unapred definisanim formularima, koji se mogu kao takvi i sačuvati. Većina dodokumenata odgovaraju standardima propisanim od strane Republičkog geodetskog zavoda Republike Srbije.

Sve ikone koje pripadaju ovom progranu su u osnovi svetlo plave (tirkizne Blanko) boje, smestene u Toolbar meni GRAC00.MNU

Pri pokušaj korišćenja programa bez Hard Lock-a, posle kraćeg testiranja dobijate poruku kojom Vam se daje mogućnost da ubacite Hard Lock:

nakon čega će, ako ga ne ubacite, AutoCAD nastavlja da radi normalno ali bez ikona i padajućeg menija koji pripadaju ovom programu.

U situacijama kada treba unositi uglovnu vrednost, uglove treba unositi u obliku:

SSS.mmss gde su: SSS - stepeni, mm - minute, ss - sekunde

U istom obliku uglovne vrednosti se i prikazuju.


Instaliranje programa

Navigation: Opšte napomene >

Instaliranje programa

 Return to chapter overview

Instalalacija je veoma jednostvna pokretanjem

AcadGRAC-Install.exe

Pojavljuju se nekoliko uvodnih dijaloga

pa zatim obaveštenje sa tekstom

Obzirom da ce deo prigrama za formiranje 3D modela programiran u .net tehnologiji, potrebno je da je na računaru instaliran Microsoft.NET Framework 2.0

Ako negova instalacija nije uključena u instalacioni program AcadGRAC-Install.exe isti se može preuzeti sa Internet adrese:

http://www.microsoft.com/downloads/details.aspx?FamilyId=7ABD8C8F-287E-4C7E-9A4A-A4ECFF40FC8E&displaylang=en

Kroz Dijalog box izjasniti se o folderu u kome se želi instalirati program koji se automatski i kreira

Kroz Dijalog box ukazati na koji AutoCAD se vezuje instalirani progran nakon čega se instalacija obavlja do kraja.

Instalacijom AcadGRAC-a u kolekciju Windows fontova dodaju se još 3 ćirilična TTF fonta i to Arial Cirilica, Helvetica Cirilica i Times Cirilica


Instalacija Driver-a za Hard Lock

Navigation: Opšte napomene >

Instalacija Driver-a za Hard Lock

 Return to chapter overview

Driver-i za Hard Lock se jednostavno instaliraju pokretanjem Install programa:

HASPAcadGRAC-Install.exe

nakon čega je računar spreman.

Obzirom da je deo programa za formiranje 3D modela programiran u .net tehnologiji, kao i to da Hard Lock Driver-i zahtevaju je da je na računaru instaliran Microsoft.NET Framework 2.0, potrevno je predhodno njega instalirati ako već nije.

Ako negova instalacija nije uključena u instalacioni program AcadGRAC-Install.exe ili HASPAcadGRAC-Install.exe isti se može preuzeti sa Internet adrese:

http://www.microsoft.com/downloads/details.aspx?FamilyId=7ABD8C8F-287E-4C7E-9A4A-A4ECFF40FC8E&displaylang=en


Podešavanje AcadGRAC ikone

Navigation: Opšte napomene >

Podešavanje AcadGRAC ikone

 Return to chapter overview

Instalacijom programa AcadGRAC, automatcki se na Desk Top-u instalira ikona

u kojoj je sve podešeno tako da nisu potrebna dodatna podešavanja.

U slučaju da nešto nije u redu treba proveriti tako što se pritiskom na desnim tasterom miša, nad ikonom, aktivirati meni

i u njemu opciju Properties pa u toj opciji na kartici Shortcut. Treba da stoji u poljima:

· Target: "C:\Program Files\AutoCAD 2002\acad.exe" /s "H:\AcadGRAC;"

gde su plavom bojom naznačeni delovi koji zavise od verzije AutoCAD-a i lokacije gde je program instaliran

· Start in folder: "H:\AcadGRAC"

folder (može biti i bilo koji drugi) u kome se AutoCAD postavlja pri svakom njegovom aktiviranju (ovom ikonom)

Pogodno je da to bude folder u kome se smeštaju crteži. (vidi primer dole)


Pregled komandi

Navigation: Opšte napomene >

Pregled komandi

 Return to chapter overview

Ikona

Opis komande

Command:

Setup GRAC-a

Parametri (SNew Linketup) GRAC-a | SetGrac
BackUp crteža | Bekap

Crtanje/Editovanje

 | Skrati/Produži sve LINE | SkratiLinS
 | LINE sa pojačanim OSNAPom na TACKU | GLine
 | LWPOLYLINE sa pojačanim OSNAPom na TACKU | GLWPLine
 | Premeštanje Det. tacke | MuvTacka
 | Unos TEKSTa horizontalno | Tekst0
 | Unos TEKSTa pod uglom | Tekst1
 | Editovanje Atributa | EditAtt
 | Upis Dužine fronta | Fron
 | Tabela koordinata tačaka | Tabot
Okvir | Insertovanje Okvira u razmeri | Okvir
 | Insertovanje tačke u LWPOLYLINE | LwpInsT
 | Izbacivanje tačke iz LWPOLYLINE | LwpDelT
 | Prekidanje LWPOLYLINE | LwpBrek

Grupni alati

 | Grupni alati za Entitete (Aselen) | Aselen
 | Grupni alati za Atribute | AselenAtt
Attvisibl | Pali/Gasi Atribut | Vidljiv

Konture i Povrsine

Gkont | Formiranje konture - LINE različitog tipa | Gkont
Kont0 | Formiranje konture - LINE istog tip | Kont0
Konparc | Formiranje konture - (Boundary) | KonParc
Autokontl | Automatsko formiranje kontura | Autokontl
 | Površina konture sa textom | Kont
 | Površina konture sa HATCH | Povr

Grac alati

 | Tačke na Upravnoj | Uprav
 | Tačke na Liniji | Nalin
 | Apscisa i Ordinata (Dule1) | Dule1
Uprav1 | Spuštanje tačke na liniju i prekidanje | Upra
Lpres | Tačka u lučnom preseku | Lpres
Prpar | Konstrukcija 4. tacke paralelograma | PrParal
FronKont | Frontovi unutar konture | FronKont

Servisni alati

 | Nadji Tačku broj: | NadjiTAC1
 | Snimi blok na (0,0) WBL | Wbl
 | Učitaj blok na (0,0) IBL | Ibl
 | Počisti crtež | Purg
 | Dodavanje bloku TACKA entitet POINT u 3D | Iz2Du3D
 | Zamena tačke (point) blokom TACKA | Iz3Du2D
Det2Tac | Zamena Detac i Kotac blokom TACKA | Detac2Tacka
Trans2 | Transformacija dela DWG | Trans2
Transform | Afina/Helmertova transformacija | Transform

Podloge/Rasteri

GracArea | Prostor insertovanja rastera | GracArea
 | Ucitavanje Detaljnog lista | InsRas
 | Ucitavanje Kopije plana | InsKop
 | Ubacivanje u bazu rastera | TabRas
 | Ucitavanje rastera | Ucrac
 | Uklapanje rastera 1. nacun | Ucrac1
 | Uklapanje rastera 2. nacun | Ucrac2
 | Ime i putanja rastera? | Imer
 | Izbacivanje rastera | Delr
Snrast | Snimanje DWG-a sa rasterima | SnRast

Unos brojeva parcela

 | Unos broja parcele | BrPar0
Brparph | CikličanUnosBrojaPARCELE H | BrParc0
Brparpk | CikličanUnosBrojaPARCELE K | BrParc1
Brparch | PojedinačanUnosBrojaPARCELE H | BrojPar0
Brparck | PojedinačanUnosBrojaPARCELE K | BrojPar1

Unos/Editovanje koordinata

 | Učitavanje iz Spiska koordinata | Ucgrac0
 | Učitavanje iz GRAC-a | Ucgrac
 | Insertovanje Det. tačke | UcDet
 | Učit/Edit Det. tačke | UcYXZ
Uckot | Insertovanje samo kote tačke | UcKOT
 | Unos iz FAJLA TC stanice u DWG | UcTCfajl

Zapisnik za Spisak koordinata

Spisak Koordinata Tačaka

To25dwg

Zapisnik za Distomat

Tahimetrijski Zapisnik

UcTahZap

Zapisnik za Ortogonal

UcUprzap

Zapisnik za Ortogonal

UcUprZap

Ostali Zapisnici (TAH, UPR)

 | Upis koordinata tačaka u TXT fajl | Spisak
Stamkont | Spisak koordinata kontura/parcela | StamKont
PyxParc | PYX formular deobe parcela | StamParc
 | Osmi po stanicama | MkTahZap
Dule2 | Zapisnik Apscise i Ordinata (Dule2) | Dule2

Digitalni topografski kljuc

 | Topografski znaci | Slideman
Pikir | Pikir | GPikir
Prip | Znak pripadnosti | Pripadnost
PonLin | Znak ponistenja linije | PonLin

Padne linije (skarpe)

Padne linije (škarpe)

Skarpa

Srafiranje

Šrafiranje paralelno | SrafirP
Šrafiranje koso | SrafirK

Cepanje parcela

 | Cepanje parcela PARALELNO | CepaP
 | Cepanje parcele RADIJALNO | CepaR
Cepaf | Cepanje parcele po FAKTIČKOM | CepaF

Interpolacija

Ekvidistantna | Interpol0
Vise kota na liniji | Interpol1
Pojedinačno izmedju 2 tačke | Interpol2

Priprema za DTM (Tin)

Unos/Edit vrednosti Ekvidistancije | IzoEkvid
Polilinija obuhvata DMT | LWPobuhvat
NEučestvuje/Učestvuje u DMT | Van3D
Povrčine bez izohipsa | KontIzo
Linije obavezne interpolacije | LineIzo
Pomoćna linija za ispis kota izohipsa | LineBro

3D triangulacija

 | 3D Triangulacija za DMT (Tin) | Triangulate
Trik | Lokalno Tinovanje | Trik
Struktri | 3D Trouglovi na obavezne linije | StrukTriang
 | Korigovanje 3D trouglova pojedinačno | TdtriLW

Izohipse

 | Interpolacija Trouglova na LINE izohipse | Interpln
 | Glačanje izohipsa (LINE u LWPOLYLINE) | Line2LWP
Ilw2sp | Glačanje izohipsa (LWPOLYLINE u SPLINE) | Lwpglac
Isp2lw | Pretvaranje izohipsa (SPLINE u LWPOLYLINE) | Spltolwp
Izonumer | Broj izohipse | BrIzohipse

Profili

Podužni i poprečni profili

CrtPr

Zapremine

Zapremina

Zaprem

Štampanje

Lou

Okvir i priprema stampe

Okvir

Layout

Vprazmera | Razmera štampanja | VPRaz
Vpcentar | Novi centar pogleda | VPRcen
Vpotvori | Odključavanje POGLEDA | VPON1
Vpzatvori | Zaključavanje pogleda | VPON0
Opiskor | Koordinate opisa Layouta | OpisKor


Osnovni Parametri AcadGRACA

Parametri (Setup) GRAC-a

Command: SetGrac

Definisanje osnovnih parametara za rad programskom paketu AcadGRAC koji se čuvaju u folderu programa pod imenom: Setgrac.txt

Kroz DodatakA

· definiše se preko prekidača da li će se pojedini podaci unositi kroz Dijalog Box ili iz Command: linije
· direktno upisivanje u crtež određenih podataka i u kom obliku.

BackUp crteza

Command: Bekap

Snimanje crteža na željenoj lokaciji i pod željenim imenom bez uticaja na putanju i ime aktuelnog crteža. Zadnja navedena lokacija BackUp se nudi u sledećem pokušaju


Crtanje/Editovanje

Skrati/Produzi sve LINE

Command: SkratiLinS

Skraćivanje svih entitata LINE za zadatu vrednost.

Ako je zadata vrednost 0.00 tada se svi entiteti LINE vaćaju na svoju stvarnu dužinu

LINE sa pojacanim OSNAPom na TACKU

Command: GLine

Crtanje entiteta LINE sa pojačanim osnapom na tačku.

U slučaju kada je aktivan samo osnap "Node" pri crtanju LINE ili LWPOLYLINE ovom komandom osnap je uvek na najbližoj tački (Insett point Bloka TACKA)

LWPOLYLINE sa OSNAPom na TACKU

Command: GLWPLine

Crtanje entiteta LWPOLYLINE sa pojačanim osnapom na tačku.

U slučaju kada je aktivan samo osnap "Node" pri crtanju LINE ili LWPOLYLINE ovom komandom osnap je uvek na najbližoj tački (Insett point Bloka TACKA)

Ako se grafički unos (pokazivanjem tačaka mišem) prekine DESNIM tasterom miša, otvara se u gornjem levom uglu Dijalog box za nastavak spajanja unošenjem Imena tačke sve dok se isti ne prekine pokazivanjem tastrera ESC u dijalogu ili pritiskom na taster ESC na tastaturi čime se vraća na grafički unos.

Premestanje Det. tacke

Command: MuvTacka

Pokazanu detaljnu tačku pomera na odabranu ili u komandnoj liniji unetu koordinatu, povlačeći za sobom sve entitete koji su za nju, vezani.

Unoc TEKSTa horizontalno

Command: Tekst0

Unos entiteta TEXT kroz Dijalog box uvek horizontalno i centralnim poravnanjen u pokazanoj tački.

Unoc TEKSTa pod uglom

Command: Tekst1

Unos entiteta TEXT kroz Dijalog box sa centralnim poravnanjen u pokazanoj tački i rotiranjem oko nje.

Editovanje Atributa

Command: EditAtt

Pokazani entitet TEXT ili ATTRIBUT, bilo kog bloka, edituje kroz Dijalog box.

Ako ste u nekom od Layout-a tada vam se otvara Dijalog box kroz koji se izjašnjavate o načinu zamene Texta ili Attributa

Ako je pokazani Atribut KOTA tacke tada se edituju i svi kreirani 3DFACE trouglovi u čijim je formiranju ta tacke ucestvovala

Upis Duzine fronta

Command: Fron

Za pokazan entitet LINE ili pokazane ili unete dve tačke, na sredini između njih u aktualnom lejeru upisuje tekst rastojanje između njih

Varijante iz Command: linije

Ispisivanje HORIZONTALNIH dužina frontova za selektirane entitete LINE SFRON

Ispisivanje HORIZONTALNIH približnih dužina frontova LINE (po uzorku) EFRON

Ispisivanje KOSIH tačnih dužina frontova LINE (po uzorku) FRONK

Ispisivanje KOSIH približnih dužina frontova LINE (po uzorku) KFRONT

Premeštanje texta FRONTA iznad i ispod linije OFRON

Tabela koordinata tacaka

Command: Tabot

Za pokazane Detaljne tačke kreira u crtežu sortiranu tabelu sa Imenom i koordinatama Y i X (prvi Atribut i Insetrt point bloka)

Upis DirUgla i Duzine

Command: Osmi2t

Za prvo pokazanu tačku kao stanicu i svaku sledeću pokazanu tačku, na pokazano mesto između njih, upisuje Direkcioji ugao i dužinu u lejeru DIR_DUZ.

Okvir

Insertovanje OKVIRA u Razm

Command: LwpInsT

Insertovanje OKVIRA u Razmeri gde se dimenzije biraju preko Dijalog Box-a kao kod Lou (Okvir i priprema Stampe).

Okvir se insertije u Modelu

Insertovanje tacke u LWPOLYLINE

Command: LwpInsT

Za selektirani entitet LWPOLYLINE, na pokazanim mestima insertuje nove tačke.

Izbacivanje tacke iz LWPOLYLINE

Command: LwpDelT

Najbližu pokazanu tačku selektiranog emtiteta LWPOLILINE izbacuje.

Prekidanje LWPOLYLINE

Command: LwpBrek

Selektirani entitet LWPOLYLINE, na pokazanim mestima prekida.


Grupni alati

Grupni alati za Entitete (Aselen)

Command: Aselen

Za selektovani entitet kao uzorak, sa svojstvima

· TIP entiteta (line, lwpolyline, Block Hatch, ....). Ako je TIP entiteta Block onda je svojstvo i Ime Bloka
· LEJER i
· BOJA

selektuju se SVI entiteti u crtežu sa tim svojstvima i nad njima se izvodi neka od sledećih operacija (koje zavise od TIP-a entiteta)

a koji se bira pritiskom na karakter koji je u opciji istaknut velikim slovom

· Delete

Selektirane entitete briše
· Explode

Selektirane entitete razbija
· Order

Upućuju na Vrh ili Dno tj. Iznad ili ispod svih ostalih entiteta
· Layercolor

Selektiranim entitetima nudi promenu: Lajer, Color, Linetype, Linetype Scale, Thickness
· Width

Selektirane entitete LINE pretvoriti u LWPOLYLINE a zatim zadaje debljinu
· lwidtH

Selektiranim entitetima LINE zadaje debljinu
· lTscale

Selektiranim entitetima zadaje Linetype Scale
· dUzina

Računa ukupna dužina selektiranih entiteta *LINE
· lIne0

Selektiranim entitetima koordinatu Z pretvoriti u 0.0
· Razmak

Selektirane entitete LINE geodetski sktaćuje za zadatu vrednost
· razmakSve

SVE entitete LINE u crtežu, geodetski sktatiti za zadatu vrednost
· Front

Selektiranim entitetima *LINE upisati na sredini dužinu
· line2N

Frontove (LINE između 2 tačke) skraćene na stari način definitivni produžuje do prve Detaljne tacke na pravcu
· Scale

Selektirane entitete skalira za unetu vrednost
· sTyle

Selektiranim entitetima menja Text Style
· Rotate

Selektirane entitete rotira na vrednost
· Zameni

Selektirane Blokove zamenjuje novim
· Ujednaci

Selektiranim Blokovima postavlja scale faktor na 1.0
· Hna0

SVIM entitetima u crteži tipa INSERT i LINE prevodi koordinatu Z u 0.0
· taCke

Selektiranim blokovima TACKA vrsi prenumeraciju imana (prvog atributa) na neki od sledećih nači

1. Dodavanje TEXT-a ispred postojeceg imena
2. Uklanjane TEXT-a iz prednjeg dela ime
3. Dodati/Oduzeti postojecem imenu-broju vrednost
4. Prenumeraciju svih selektiranih tacaka zapoceti brojem
· Xscale

Selektirane blokove SKARPA skalira po širinu (menja razmak između linij)
· Visina

Selektiranim entitetima *TEXT menja Visinu karaktera
· Faksir

Selektiranim entitetima *TEXT menja Faktor širine kataktera
· Mustra

Selektiranim entitetima HATCH menja tip hatca
· Detach

Selektirane rastere briše
· Transparent

Selektirane rastere ptavi transparentnim ako je to moguće
· Breack

Selektirane entitete LINE međusobno prekida na mestima na kojima su se osnapom "nearest" "zakačile" jedna na drugu
· Poklin

Od selektiranih entiteta LINE briše koje se medjusobno preklapaju i ostavlja jednu koja poklapa sve obrisane

Grupni alati za Atribute

Command: AselenAtt

Za selektovani Atribut kao uzorak, sa svojstvima

· BLOCK entitet kome pripada pokazani Atribut
· IME pokazanog Atributa
· LEJER i
· BOJA

selektuju se SVI Atributi u crtežu sa tim svojstvima i nad njima se izvodi neka od sledećih operacija a koji se bira pritiskom na karakter koji je u opciji istaknut velikim slovom

· Delatt

Pokazani Atribut u svim blokovima pretvara u "" [blanko]

· Scalatt

Skalira samo pokazani Atribut u svim blokovima
· Visinaatt

Menja Visinu pokazanog Atributa u svim blokovima
· Faksirine

Menja Faktor širine pokazanog Atributa u svim blokovima
· sTyltextatt

Menja Stil Texta pokazanog Atributa u svim blokovima
· Atribut

Vrednost pokazanog Atributa u svim blokovima množi ili sabira sa unetom vrednošću
· Layer

Menja Lajer pokazanog Atributa u svim blokovima
· Color

Menja Color pokazanog Atributa u svim blokovima
· vIdljivost

Menja Vidljivost pokazanog Atributa u svim blokovima
· Brojdec

Editovanje broja decimala vrednost Atributa kote tacke

Attvisibl

Pali/Gasi Atribut

Command: Vidljiv

Svi Atributi u crtežu sa svijstvima kao pokazani uzorak Atributa postaju nevidljivi (gase se).

Ako se pokaže neatributski deo bloka (deo bloka koji je crtež, kod bloka TACKA, pikir) tada se SVI atributi tog bloka u celom crtežu čine vidljivim


Konture i Površine

Gkont

Formiranje kontura - linije razlicitog tipa

Command: Gkont

Za pokazanu tačku detektuje zatvorenu konturu koristeći entitete LINE i istu iscrtava u vidu LWPOLYLINE entiteta.

Komanda reaguje automatski na dva načina:

· Ako je pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a "zakačen" i neki entitet LINE tada se zarvorena kontura traži samo od entiteta LINE njenih svojstava
· Ako pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a nije "zakačen" ni jedan entitet LINE tada se zarvorena kontura traži od svih entiteta LINE

Nakon pozitivnog odgovora da je detektovana kontura dobra, pokazati mesto upisivanja teksta vrednosti površine

Kont0

Formiranje kontura - linije istog tipa

Command: Kont0

Za pokazanu tačku detektuje zatvorenu konturu koristeći entitete LINE i istu iscrtava u vidu LWPOLYLINE entiteta.

Komanda reaguje automatski na dva načina:

· Ako je pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a "zakačen" i neki entitet LINE tada se zarvorena kontura traži samo od entiteta LINE njenih svojstava
· Ako pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a nije "zakačen" ni jedan entitet LINE tada se zarvorena kontura traži od svih entiteta LINE

Nakon pozitivnog odgovora da je detektovana kontura dobra, pokazati mesto upisivanja teksta vrednosti površine

Konparc

Formiranje kontura (Baundary)

Command: KonPatc

Za pokazanu tačku detektuje zatvorenu konturu koristeći entitete LINE i istu iscrtava u vidu LWPOLYLINE entiteta.

Komanda reaguje automatski na dva načina:

· Ako je pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a "zakačen" i neki entitet LINE tada se zarvorena kontura traži samo od entiteta LINE njenih svojstava
· Ako pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a nije "zakačen" ni jedan entitet LINE tada se zarvorena kontura traži od svih entiteta LINE

Nakon pozitivnog odgovora da je detektovana kontura dobra, pokazati mesto upisivanja teksta vrednosti površine

Autokontl

Automatsko formiranje kontura

Command: Autokontl

Za pokazani entitet LINE detektuje sve zarvorene konture od entiteta LINE sa svojstvima kao pokazani uzorak LINE.

Povrsina konture sa textom

Command: Kont

Za pokazanu tačku detektuje zatvorenu konturu koristeći entitete LINE i istu iscrtava u vidu LWPOLYLINE entiteta.

Komanda reaguje automatski na dva načina:

· Ako je pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a "zakačen" i neki entitet LINE tada se zarvorena kontura traži samo od entiteta LINE njenih svojstava
· Ako pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a nije "zakačen" ni jedan entitet LINE tada se zarvorena kontura traži od svih entiteta LINE

Nakon pozitivnog odgovora da je detektovana kontura dobra, pokazati mesto upisivanja teksta vrednosti površine

Povrsina konture sa HATCH

Command: Povr

Za pokazanu tačku detektuje zatvorenu konturu koristeći entitete LINE i istu iscrtava u vidu LWPOLYLINE entiteta.

Komanda reaguje automatski na dva načina:

· Ako je pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a "zakačen" i neki entitet LINE tada se zarvorena kontura traži samo od entiteta LINE njenih svojstava
· Ako pri pokazivanju tačke unutar konture, dimenzijama PICKBOX-a nije "zakačen" ni jedan entitet LINE tada se zarvorena kontura traži od svih entiteta LINE

Nakon pozitivnog odgovora da je detektovana kontura dobra, pokazati mesto upisivanja teksta vrednosti površine


Grac alati

Tacke na Upravnoj

Command: Uprav

Računanje koordinata tačaka na upravnoj. Pozitivan smer upravne je DESNO gledano u pravcu linije od T1 ka T2

Za pokazanu ili unetu tačku T1 kao početak linije i pokazanu ili unetu tačku T2 kao drugu tačku linije, umesto ponuđene dužine iz koordinata između tih tačaka uneti merenu dužinu

dalje na unetu Apscisu i ordinatu nudi da se unese ime tačke i tako u ciklusima

Insertovanje se vrči u aktivnom lejeru a atributi bloka TACKA preuzimaju boje postojećih artibuta istog bloka.Ako blok ne postoji u tom lejeru, svi delovi bloka preuzimaju boju lejera.

Tacke na Liniji

Command: Nalin

Računanje koordinata i insertovanje tačaka na liniji

Za pokazanu ili unetu tačku T1 kao početak linije i pokazanu ili unetu tačku T2 kao drugu tačku linije, uz izjašnjavanje da li se racunanje vrši Apscisno ili Parcijalno

(Apscisno: dužina je uvek od početne tačke linije T1)

(Parcijalno: dužina je uvek od predhodno sračunate tačke)

računaju i insertuju se koordinate tačaka i nudi da se unese ime tačke i tako u ciklusima

Insertovanje se vrči u aktivnom lejeru a atributi bloka TACKA preuzimaju boje postojećih artibuta istog bloka.Ako blok ne postoji u tom lejeru, svi delovi bloka preuzimaju boju lejera.

Apscisa i Ordinata (Dule1)

Command: Dule1

U odnosu na pokazane ili unete tačke T1 i T2 kojima se definše linija Apscise sa pozitivnim smerom Ordinate desno ya svaku dalju pokazanu tačku dobijaju se Apscisa i Ordinata

Prikaz trenutno ovako sračunatih Apscisa i Ordinata vrši se komandom Dule2 (Dule2) kao Excel dokument

Uprav1

Spustanje tacke na liniju i prekidanje

Command: Upra

Na selektiranu LINE ili dvema tackama definisanu liniju u ciklusu svaka sledeća pokazana tačka projektuje se na pokazanu liniju, insertuje se blok: TACKA i u njoj osnovna linija, prekida.

Lpres

Tacka u lucnom preseku

Command: Lpres

U odnosu na pokazane ili unete tačke T1 i T2 i zatim pokazanu stranu, za uneta udaljenja od tacke T1 i T2 u lučnom preseku insertuje se blok: TACKA

Prpar

Konstrukcija 4. tacke paralelograma

Command: PrParal

U odnosu na pokazane krajeve dve LINE konstruiše se paralelogram i insertuje se blok: TACKA

FronKont

Frontovi unutar konture

Command: FronKont

Na pokazanu tacku detektije postojeću ili formira novu konturu i za nju upisuje vrecnosti frontove (na 2 decimale) orijentisane unutar konture

U nastavku komande daje se mogućnost da se pokazane vrednosti frontova preseljavaju iznad i ispod linije fronta naizmenično.


Servisni alati

Nadji Tacku broj:

Command: NadjiTAC1

Pronalaženje tacke (blocka: TACKA) po imenu i dovođenje te tačke u centar ekrana

Snimi blok na (0,0) WBL

Command: Wbl

Kreiranje bloka pod imenom QQ od selektiranih entiteta sa insertnom tačkom (0 0)

Pogodno za prenišenje delova crteža iz jednog u drugi zadržavajući koordinatni sistem

Ucitaj blok na (0,0) IBL

Command: Ibl

Insertovanje zadnjeg kreiranog bloka pod imenom QQ na tačku (0 0)

Pocisti crtez

Command: Purg

Izvršavanje klasične AutoCAD kommanda PURGE za čišćenje crteža od svega suvišnog ali u ciklus gde se ista izvršava uz stalnu promenu aktivnog lejera.

Dodavanje bloku TACKA entitet POINT u 3D

Command: Iz2Du3D

Dizanje svih entiteta crteža bloka TACKA i LINE u 3D tj. prevođenje insertne tačke entiteta LINE i bloka TACKA sa svim Atributina u 3D.

Zamena tacke (point) blokom TACKA

Command: Iz3Du2D

Spuštanje svih entiteta crteža bloka TACKA i LINE u 2D tj. prevođenje insertne tačke entiteta LINE i bloka TACKA sa svim Atributina u 2D.

Det2Tac

Zamena Detac i Kotac blokom TACKA

Command: Detac2Tacka

Zamena starih blokova DETAC, KOTAC i PIKIR koji su u ranijim verzijama preuzimanja podataka iz starog GRAC paketa u AutoCAD, predstavljali Detaljnu tacku, novim jedinstvenim blokom TACKA sa 3 Atributa IMTAC, KOTAC i OPTAC.

U slučaju da je u crtežu tačka predstavljena samo blokom TACKA, tada se naizmenilno:

Atributi se skupljaju u 1 lejer ili se razvrstavaju u 3 lejera tj.svaki Atribut u svoj lejer

Trans2

Transformacija dela DWG

Command: Trans2

Selektirani deo crteša preseljava se i transformiše (objedinjene komande: move, rotate i scale) u odnosu na 2 pokazane tačke na lokaciju respektivno pokazane druge 2 tačke u drugom delu crteša.

U Command: liniji komandom USUSZONU formira se novi Layout "Susedna ZONA" i u njoj crtež iz "Modela" transformisan u SUSEDNU ZONU

Transform

Afina/Helmertova transformacija

Command: Transform

Sve tačke u crtežu (svi blokovi TACKA) transformišu se po želji Afinom ili Helmertovom transformacijom iz sistema A u sistem B uz pomoć transformacionog polja.

Transformaciono polje čine 4 tačake sa koordinatama u oba sistema smeštenih u fajl, prvenstveno i najbolje sa extenzijom "*.trn" ali može i sa bilo kojom drugom.

Formiranje novog transformacionog polja podrazumeva da se

· unesu imena i njihove koordinate u oba sistema ili
· unesu samo koordinate tih tačaka iz sistema B u koji se transformišu ali zato iste moraju biti u crtežu sa koordinatama u sistemu A, koje se transformišu.

Kada se učita formirano transformaciono polje, uz koordinate tih tačaka prikazuju se veličine popravka kao i srednja kvadratna greška tog polja sa mogućnošću editovanja tih koordinata, Isključenjem ili Uključenjem (znak + na početku sloga) pojedinih tačaka iz procesa definidanja koeficijenata transformacije, dodavanjem novih tačaka u polje kao i snimanje koordinata polja.

Transformacija se vrši pritiskom na taster Trans > čime se sve koordinate u crtežu automatski transtormišu u suprotni koordinatni sistem.


Podloge/Rasteri

Navigation: »No topics above this level«

Podloge/Rasteri

 Return to chapter overview

Potreba da se skenirane geodetske podloge raznih razmera i ostali bilo koji rasteri jednostavno, insertuju u crtež na poziciju, koji taj raster predstavlja, omogućeno je u za proizvoljan broj lokacija rada. Za svaki prostor potrebno je definisati folder prostora rada

FolderPrograma\PODLOGE\ProstorRada\

kao na primer:

H:\AcadGRAC\Podloge\Beograd\

H:\AcadGRAC\Podloge\Golubac\

H:\AcadGRAC\Podloge\Majdanpek\

H:\AcadGRAC\Podloge\Novi Sad\

koji se komandom GracArea (Prostor insertovanja rastera) u istom crtežu može više puta menjati

Da bi se pri insertovanju došlo do koordinatnog sistema prostora rastera potrebno je da za svaki prostor postoji crtež sa zeljenom interpretacijom prostora na koji se rasteri (Detaljni Listovi i kopije) odnose, pod imenom

FolderPrograma\PODLOGE\ProstorRada\00ProstorRada.DWG

Baze rastera Detaljnih Listova prostora smeštene su u podfolderu prostora:

FolderPrograma\PODLOGE\ProstorRada\DETLIST\

Baze ostalih rastera (Kopija plana, projekat ...) prostora smeštene su u podfolderu prostora:

FolderPrograma\PODLOGE\ProstorRada\KOPIJA\

Insetrovanje rastera se može vršiti u 3 varijante:

1. Komandom [image] pojedinačno insertovanje klasičnih Detaljnih listova (kod kojih su predhodno odklonjene deformacije i odbačene margine).
2. Komandom [image] pojedinačno insertovanje Kopija plana (bilo kog rastera) što podrazumeva da su podaci potrebni za insertovanje smešteni u fajl

FolderPrograma\PODLOGE\ProstorRada\DETLIST\TABELA0.TXT u

uređenom formatu

1-34 (33) ime rastera sa extenzijom

34-44 (11) faktor skaliranja

46-56 ( 9) horizontalna dimenzija prostora koji prekriva list

58-67 ( 9) vertikalna dimenzija prostora koji prekriva list

69-78 ( 9) horizontalna koordinata donjeg levog ugla list

80-89 ( 9) vertikalna koordinata donjeg levog ugla list

91-100 ( 9) ugao rotacije lista

primer jednog sloga:

1NS-001.tif                         1000.000      900.00     600.00 7408200.00 5019000.00   0.000000

3. Insertovanje proizvopljnog rastera na proizvoljnu poziciju komandom [image] , koga je dalje potrebno u odnosu na 2 tačke uklopiti u ctrež komandom [image] ili

Svaki raster insertovan u crtež moguće je zabeležiti u bazu komandom [image] , čime je omogućeno njegovo ponovi insertovanje u bilo kom trenutku u bilo kom crtežu na tom prostoru.

Jednostavnije izbacivanje rastera iz ctreža komandom [image] gde se u pokazanoj tački detektuju svi rasteri i ako ih je više od jednog, kroz Dijalog Box se bira raster koji se izbacuje.


Podloge/Rasteri

Navigation: Podloge/Rasteri >

Podloge/Rasteri

 Return to chapter overview

GracArea

Prostor insertovanja rastera

Command: GracArea

Definisanje prostora iz koga se želi insertovati raster

Ucitavanje Detaljnog lista

Command: InsRas

Pojedinačno insertovanje klasičnih Detaljnih listova (sa odklonjenim deformacijama i bez margina) iz baze

Ako predhodno nije definisan prostor traži se njegovo definisanje.

Ako u pokazanoj tački postoje više rastera tada je potrebno dodatno izjašnjenje koji se raster želi insertovati

Ucitavanje Kopije plana

Command: InsKop

Pojedinačno insertovanje ostalih rastera iz baze

Ubacivanje u bazu rastera

Command: TabRas

Upisivanje u bazu rastera insertovani i uklopljeni raster i njegovo fiyičko kopiranje u prostor baze rastera

Ucitavanje rastera

Command: Ucrac

Pojedinačno insertovanje ostalih rastera sa bilo koje lokacije na proizvoljnu poziciju koga je dalje potrebno u odnosu na 2 tačke uklopiti u ctrež

Uklapanje rastera 1. nacun

Command: Ucrac1

Uklapanje rastera u crtež gde se najpre pokažu dve tačke na RASTERU a zatim pokažu ili ukucaju njihove odgovarajuće tačke na CRTEŽU

Uklapanje rastera 2. nacun

Command: Ucrac2

Uklapanje rastera u crtež gde se najpre pokaže 1. tačka na RASTERU i odmah odgovarajuća tačka na CRTEŽU a zatim pokaže 2. tačka na RASTERU i odmah odgovarajuća tačka na CRTEŽU

Ime i putanja rastera?

Command: Imer

Za pokazani raster prikazuje njegovo ime i putanju.

Izbacivanje rastera

Command: Delr

Izbacivanje rastera iz ctreža gde se u pokazanoj tački detektuju svi rasteri i ako ih je više od jednog, kroz Dijalog Box se bira raster koji se izbacuje (kao i pri insertovanju).

Pažnja: Nije potrebno selektovati entitet rastera po njegovom okviru već je dovoljno pokazati bilo gde unutar rastera

Snrast

Snimanje DWG-a sa rasterima

Command: SnRast

Snimanje crteža na željenu lokaciju sa željenim imenom i na istu lokaciju kopiranje svih rastera koji su korišćeni u crteži

Ako se crtežu ne dodeli ime, imenuje se sa Podloge0.


Brojeva parcela

Navigation: »No topics above this level«

Brojeva parcela

 Return to chapter overview

Broj parcele je blok: BROJ

Lejer u koji se uvek insertuje broj parcele je: "BR-Parcele"

Sledeći broj parcele se generiše uvek

· ako je ceo broj, uvećavanjem za 1 celobrojne vrednosti
· ako je broj u vidu razlomka, uvećavanjem za 1 razlomačkog dela broja

Radi lakšeg i bržeg unosa dato je više varijanti unosa


Unos brojeva parcela

Navigation: Brojeva parcela >

Unos brojeva parcela

 Return to chapter overview

Unos broja parcele

Command: BrPar0

Unos broja parcele pojedinačno gde se broj unosi u komandnoj liniji

Brparph

CiklicanUnosBrojaPARCELE H

Command: BrParc0

Ciklični unos broja parcele, uvek horizontalno, gde se uvek u Dijalog Boxu nudi sledeći broj

Brparpk

CiklicanUnosBrojaPARCELE K

Command: BrParc1

Ciklični unos broja parcele sa rotacijom, gde se uvek u Dijalog Boxu nudi sledeći broj

Brparch

PojedinacanUnosBrojaPARCELE H

Command: BrojPar0

Ciklični horizontalni unos broja parcele uvek horizontalno, gde se camo na početku ciklusa u Dijalog Boxu nudi unos broja a zatim insertuju novogenerisani brojevi do prekida ciklusa

Brparck

PojedinacanUnosBrojaPARCELE K

Command: BrojPar1

Ciklični horizontalni unos broja parcele sa rotacijom gde se na početku ciklusa u Dijalog Boxu nudi unos broja a zatim insertuju novogenerisani brojevi do prekida ciklusa


Unos/Zapisnici

Navigation: »No topics above this level«

Unos/Zapisnici

 Return to chapter overview

Detaljna tačka je blok TACKA sa pikirom (entitetima Solid HATCH prečnika 0.1 i POINT) u mestu insertovanja i 3 Atributa

1. IMTAC Ime tačke
2. KOTAC Kota tačke
3. OPTAC Opis tačke koji se ne koristi i čija je vidljivost isključena

Pikir i Atributi bloka su u istom lejeru (inicijalno u lejeru "0") i boje ByBlock

Insertovanje bloka (Pikira i Atributa) vrši se u Aktuelnom lejeru dok Atributi poprimaju Aktuelnu boju

Promena boja Atributima vrši se komandom [image] (Grupni alati za Atribute)

Promena vidljivosti Atributima vrši se komandom Attvisibl (Pali/Gasi Atribut)


Unos/Editovanje koordinata

Navigation: Unos/Zapisnici >

Unos/Editovanje koordinata

 Return to chapter overview

Ucitavanje iz Spiska koordinata

Command: Ucgrac0

Učitavanje koordinata iz bilo kog tekstualnog fajla sa bilo kojom extenzijom pod uslovom da su podaci poređani u redosledu:

1. IME tacka može biti u navodnicoma ali ne mora
2. Y koordinata
3. X koordinata
4. H kota ako je ima

separator između podataka može biti: blanko, tab, zarez.

Mogu se učitavati koordinate iz EXCEL dokumenta ako se kroz Dialog Box zadaju parametri o početnim pozicijama pojedinih koordinata u EXCEL dokumentu

Za učitavanje svih redova tj. za učitavanje do prvog praznog reda, u Dijalogu, polje Zadnji: isprazniti.

Ucitavanje iz GRAC-a

Command: Ucgrac

Učitavanje koordinata i crteža formiranog DOS programskim paketom GRAC

Insertovanje Det. tacke

Command: UcDet

Pojedinačno insertovanje Detaljne tacke (Blok: TACKA) birajući mesto ili unoseći u komandnoj liniji koordinate u vidu Y,X sa automatskim dodeljivanjem imena.

Nakon umošenja imena (broja) tačke brojeni se sami generišu kontrolišući da li takav broj već postoji.

Insertovanje se vrči u aktivnom lejeru a atributi bloka TACKA preuzimaju boje postojećih artibuta istog bloka.Ako blok ne postoji u tom lejeru, svi delovi bloka preuzimaju boju lejera.

Ucit/Edit Det. tacke

Command: UcYXZ

Pojedinačno Unošenje ili Editovanje detaljne tacke (Blok: TACKA) koristeći taster ENTER za završetak unosa vrednosti.

Ako se unese ImeTAC koje ne postoji u crtežu, tada se omogućava unos nove tačke

Ako se unese ImeTAC koje već postoji u crtežu, tada se omogućava editovanje te tačke.

Editovanje koordinate se automatski odražava u crtežu, tako da se editovana tačka pomera na unetu pozicija povlačeći za sobom sve entitete koji su za nju, vezani.

Insertovanje se vrši u aktivnom lejeru a atributi bloka TACKA preuzimaju boje postojećih artibuta istog bloka.Ako blok ne postoji u tom lejeru, svi delovi bloka preuzimaju boju lejera.

Uckot

Insertovanje samo kote tacke

Command: UcKOT

Insertovanje bloka TACKA i unos samo 2. Atributa KOTA

Insertovanje se vrši u aktivnom lejeru a atribut KOTA preuzimaju boje postojećih artibuta istog bloka.Ako blok ne postoji u tom lejeru, svi delovi bloka preuzimaju boju lejera

Unos iz FAJLA TC stanice u DWG

Command: UcTCfajl

Učitavanje u crtež podataka preuzetih iz Totalnih Stanica i smeštenih u fajl za instrumente:

· Leica
· Sokia
· Nikon
· Topkon
· Trimbl

Ako su iz TC preuzete koordinate tačaka tada se iste direktno insertuju u crtež a ako su to mereni podaci uglovi i dužine tada se isti pojavljuju u zapisnik

u kome je moguće njihovo editovanje i preračunavanje a zatim opcijom OK insertovanje u crtež.

Opcijom Esc odustaje se od njihovog insertovanja u crtež.

U slucaju da nisu prepoznati podaci, porukom se obavestavamo o tome


Zapisnik za Spisak koordinata

Navigation: Unos/Zapisnici >

Zapisnik za Spisak koordinata

 Return to chapter overview

Spisak Koordinata Tacaka

Command: To25dwg

Zapisnik za Unos i Editovanje koordinata tačaka (blok: TACKA)

Unos podataka za slog na kome je tabelarni kursor vrši se u liniji za editovanje ispod tabele, gde se završetak unosa u polju (prelazak u sledeće polje) vrši pored konvencijalnih načina i tasterom ENTER

Ceo red je unet ako se u liniji za editovanje sa unosom prođe kroz sva dostupna polja za taj unos

OPIS OPCIJA IZ OSNOVNOG DIJALOG BOX-a

Automatski | Automatsko doreljivanje broja tačke pri unošenju
Manuelno | Ručno doreljivanje broja tačke pri unošenju
Aktivne | Aktiviranje polja za Unos i Editovanje kota
NeAktivne | Blokiranje polja za Unos i Editovanje kota
Selekt> | Prelazak na Selektiranje
UnosYXZ | Prelazak na Unos koordinata
Delete | Sa pozicije tabelarnog kursora brišu se svi podaci
Snimi | Snimanje trenutnih podataka zapisnika pod aktuelnim imenom
SnimiAs | Snimanje trenutnih podataka zapisnika sa mogućnošću promene imena
Stampaj | Formira se Excel dokument sa trenutnim podacima koji se može sačuvati i štampati
Esc | IZLAZAK iz zapisnika i odustajanje od svega do sada radjenog u zapisniku
OK | Preračunavanje zapisnika, njegovo snimanje i insertovanje tačaka u crtež

DIJALOG BOX-a za SELEKTIRANJE

Da bi se tacke selektirale nekontinuirano, najbolje je koristiti pritisnut taster na tastaturi Ctrl i Levi taster Misa

OPIS OPCIJA IZ DIJALOG BOX-a za SELEKTIRANJE

Geog/Zona

Za selektirane tacke računaju se Geografske koordinate fl i koordinate u susednoj zoni i u vidu Excel dokumenta prikazuju

Alternativa u Command: liniji

FILA za pokazanu tačku pokazuji se i upisuju u crtež (ako je uključen prekidač kroz SetGrac) Geografske koordinate fl

SUZO za pokazanu tačku pokazuji se i upisuju u crtež (ako je uključen prekidač kroz SetGrac) koordinate u susednoj ZONI

USUSZONU formira se novi Layout "Susedna ZONA" i u njoj crtež iz "Modela" transformisan u SUSEDNU ZONU

Pronadji

Da bi se pronašla i selektirala neka tačka po imenu potrebno je u liniji za editovanje u polju za unos tačke uneti njeno ime

Ako se želi selektirati grupa tačaka po imenu potrebno je u liniji za editovanje u polju za unos tačke uneti početni deo imena i *

Ako se želi selektirati tačaka najbliža nekoj koordinati, potrebno je u liniji za editovanje u polju za unos Y-koord i X-koord uneti koordinate

RenumSEL

Selektirane tačke se mogu prenumerisati na neki od izabranih načina ponuđenih u meniju

SnimiSEL

Snimanje seleptiranih tačaka u fajl

DeletSEL

Brisanje selektiranih tačaka

StampSEL

Formira se Excel dokument sa selektiranim tačkama koji se može sačuvati i štampati

<NAZAD

Povratak u osnovni dijalog zapisnika


Zapisnik za Distomat

Navigation: Unos/Zapisnici >

Zapisnik za Distomat

 Return to chapter overview

Tahimetrijski Zapisnik

Command: UcTahZap

Zapisnik snimanja tačaka polarnom metodom distomatom

Unos podataka za slog na kome je tabelarni kursor vrši se u liniji za editovanje ispod tabele, gde se završetak unosa u polju (prelazak u sledeće polje) vrši pored konvencijalnih načina i tasterom ENTER

Ceo red je unet ako se u liniji za editovanje sa unosom prođe kroz sva dostupna polja za taj unos

Ako je na početku sloga:

$ to je oznaka da je taj slog stanica

@ to je oznaka da je taj slog orijentacija

[blanko] to je oznaka da je taj slog detaljna tačka

Prikaz koordinata tačke na kojoj je tabelarni kursor je u prostoru iza Y.X.Z:

Pri unosu podataka u polja kontrolišu se kod

· datih tačaka da li ista ne postoji
· detaljnih tašaka da li ista postoji
· uglovnih vrednisti ispravnost unetog ugla

Prilikom Unosa ili Editovanja imena tačke Stanice ili Orijentacije, ako ista ne postoji u crtežu ili do tada nije uneta ili sračunata, automatski se otvara mogućnost da se njene koordinata unesu tj. prelazi na opciju YXZ.

OPIS OPCIJA IZ DIJALPG BOX-a

YXZ | kada je tabelarni kursor na "Datoj tacki" (Stanica ili Orijentacija) daje se moguđnost Unos/Editovanja koordinata te tačke
Naz | kada stanica ima 3 ili više orijentacina pruža se mogućnost da se koordinate te stanice sračunaju presecanjem nazad (sa izravnanjem) i naj povoljnijim presecanjem u stranu (Ekscentrična stanica). Opcijom OK stanica dobija koordinate izabranog računanja u protivnom stanica ne dobija koordinate.
Automatski | Automatsko doreljivanje broja tačke pri unošenju
Manuelno | Ručno doreljivanje broja tačke pri unošenju
Kosa | Dužina je kosa (isti efekat je ako se u polju za unos dužine na kraju unete dužine doda / [kosa crta])
Horizont | Dužina je horizontalna (isti efekat je ako se u polju za unos dužine na kraju unete dužine doda - [minus])
Bez kota | Rad sa horizontalnim dužinama i bez vertikalnih uglova (isti efekat je ako se u polju za unos dužine na kraju unete dužine doda [blanko] ili ne doda nista)
Stanica | Tačka je stanica (isti efekat je ako se u polju za unos imena ispred imena doda $)
Vizura | Tačka je vizura (orijentacija) (isti efekat je ako se u polju za unos imena ispred imena doda @)
Detaljna | Tačka je detaljna (isti efekat je ako se u polju za unos imena ispred imena doda [blanko])
Unos DET | Prelazak na unos tačaka
InST | Na poziciji tabelarnog kursora insetruje se stanica u daje mogućnost da se unesu njeni podaci
InDT | Na poziciji tabelarnog kursora insetruje se detaljna tačka u daje mogućnost da se unesu njeni podaci
Delete | Sa pozicije tabelarnog kursora brišu se svi podaci
Snimi | Snimanje trenutnih podataka zapisnika
Stampaj | Formira se Excel dokument sa trenutnim podacima koji se može sačuvati i štampati
Esc | IZLAZAK iz zapisnika i odustajanje od svega do sada radjenog u zapisniku
OK | Preračunavanje zapisnika, njegovo snimanje i insertovanje tačaka u crtež


Zapisnik za Ortogonal

Navigation: Unos/Zapisnici >

Zapisnik za Ortogonal

 Return to chapter overview

UcUprzap

Zapisnik za Ortogonal

Command: UcUprZap

Zapisnik snimanja tačaka polarnom metodom distomatom

Unos podataka za slog na kome je tabelarni kursor vrši se u liniji za editovanje ispod tabele, gde se završetak unosa u polju (prelazak u sledeće polje) vrši pored konvencijalnih načina i tasterom ENTER

Ceo red je unet ako se u liniji za editovanje sa unosom prođe kroz sva dostupna polja za taj unos

Prikaz koordinata tačke na kojoj je tabelarni kursor je u prostoru iza Y.X.Z:

Pri unosu podataka u polja kontrolišu se kod

· datih tačaka da li ista ne postoji
· detaljnih tašaka da li ista postoji

OPIS OPCIJA IZ DIJALPG BOX-a

YXZ | kada je tabelarni kursor na SLOGU "Linija" daje se mogućnost Unos/Editovanja koordinata tačkaka linije za snimanje
Automatski | Automatsko doreljivanje broja tačke pri unošenju
Manuelno | Ručno doreljivanje broja tačke pri unošenju
Linija | Slog linije ya snimanjegde su imena tačaka linije i merene dužine između njih
Detaljna | Slog detaljne tačke sa Apscisom i Ordinatom
Unos DET | Prelazak na unos detaljnih tačaka
InLN | Na poziciji tabelarnog kursora omogućava se Unos ili Editovanje podataka linije snimanja
InDT | Na poziciji tabelarnog kursora omogućava se Unos ili Editovanje podataka za detaljnu tačku
BrisiRed | Sa pozicije tabelarnog kursora brišu se svi podaci
SnimiZap | Snimanje trenutnih podataka zapisnika
SnimiZapAs | Snimanje trenutnih podataka zapisnika pod željenim imenom
Stampaj | Formira se Excel dokument sa trenutnim podacima koji se može sačuvati i štampati
Esc | IZLAZAK iz zapisnika i odustajanje od svega do sada radjenog u zapisniku
OK | Preračunavanje zapisnika, njegovo snimanje i insertovanje tačaka u crtež


Ostali Zapisnici (TAH, UPR)

Navigation: Unos/Zapisnici >

Ostali Zapisnici (TAH, UPR)

 Return to chapter overview

Upis koordinata tacaka u TXT fajl

Command: Spisak

Za pokazane uzorke blokva, odabrani broj decimala i pozitivno izjašnjenje na pitanje "Pravite spisak za CEO crtez?:" u odabranom ptostoru i pod željenim imenom fajla, sneštaju se Prvi Atribut i Z,X koordinate (insert point bloka) a za kotu se uzima Drugi Atribut ako ga ima sa extenzilom .TXT i drugi fajl sa extenzijom .ZXY kao export za DOS programski paket GRAC

Stamkont

Spisak koordinata kontura/parcela

Command: StamKont

Za pokazane LWPOLYLINE zatvorene konture formira Spisak koordinata i površina u vidu Excel dokumenta

PyxParc

Spisak koordinata kontura/parcela

Command: StamParc

Za pokazane brojeve parcela, dobijene deobom neke parcele, formira se PYX zapisnik deobe tih parcela sa spisakom koordinata i površina novoformiranih parcela i popravkama u odnosu na "Administrativnu" (površinu iz operata) početne parcele, u vidu Excel dokumenta

Završetak selektiranja brojeva parcela za koje se formira PYX zapisnik, obavlja se pritiskom na DESNI taster miša.

Odustajanje od prosesa obavljase tasterom tastature ESC.

Osmi po stanicama

Command: MkTahZap

U slucaju kada je situacija uradjena (gde su detaljne tačke blok: TACKA) a želi se napraviti novi Tahimetrijski zapisnik za detaljne tačke, koje su u uključenim lejerima i sa uključenim atributima, kroz Dijalog box se izjašnjavate

U prvoj varijantni (bez ikatve predhodne pripreme) pokazujući kursorom miša najpre stanicu pa zatim 1. pa 2. orijentaciju a zatim detaljne tačke i za kraj pitiskom na desni taster miša kreita se Excel dokument kao Tahimetrijski zapisnik u pokazanom redosledu tačaka.

U drugoj varijanti, treba kao pripremu za to u lejeru "TAH-obuhvati i pravci" formirati entitete :

· LWPOLYLINE obuhvati stanica
· LINE orijentacioni pravci
· BLOCK-om "BROJUCIRC" obeležja stanice sa atributom koji predstavlja redni broj stanice. ž

Startovanjem programa automatski se kreira traženi lejer "TAH-obuhvati i pravci" i ako u njemu ne postoje obeležja stanica prelazi se na njihovo obeležavanje.

Po obeležavanju stanica ponovo startovati program i pokazati uzorke:

1. poliliniju obuhvata stanice
2. blok obeležja stanice i
3. liniju orijentacije

Odgovarajući pozitivno na pitanje "Vrsite prenumeraciju brojeva detaljnih tacaka u ZAPISNIKU i CRTEZU?:" omogućiće se prenumeracija detaljnih tačaka u okviru obuhvata stanica, od 1 pa nadalje, izostavljajući tačke geodetske osnove, stanica i orijentacija, istovremeno sortirajući ih po uglovima i dužinama u okviru stanica.

Ako je već rađena prenumeracija detaljnih tačaka, ponudiće se pitanje "Vracate ORIGINALNE brojeve tacaka:" čime se daje mogućnost da se povrate originalni brojevi prenumerisanih tačaka.

Ako je u bilo kom crtežu, bilo kada, vršena prenumeracija tačaka ovim programom, moguće je u komandnoj liniji komandom ORIGIMTAC povratiti originalna imena tačaka.

Nakon obrade, u crtežu će biti markirane sve tačke koje su uključene u Tahimetrijski zapisnik i formiraće se Excel fajl Tahimetrijskog zapisnika.

Dule2

Zapisnik Apscise i Ordinata (Dule2)

Command: Dule2

Ako su predhodni komandom [image] (Dule1) sračunate Apscise i Ordinate u Excel dokumentu se iste prikazuju u vidu zapisnika


Topografija

Navigation: »No topics above this level«

Topografija

 Return to chapter overview

Insertovanje topografskih znakova, u skladu sa Digitalnim topografskim ključem, Verzija 1.0 iz jula 2005. godine objavljenog od Republičkog geodetskog zavoda Republike Srbije.

Insertovanje se vrši u aktuelnom lejeru.

Šrafura objekata se insertuju bez obzira da li su LINE skraćene.


Digitalni topografski ključ

Navigation: Topografija >

Digitalni topografski ključ

 Return to chapter overview

Topografski znaci

Command: Slideman

Startovanjem komande u Dijalog Box-u izjašnjava se o tipu, podtipu i samom znaku nakon čega se vrši na svim pokazamom pozicijama.

Pri insertovanju, faktor skaliranja znaka se usklađuje prema Razmeri crtanja definisanoj kroz komandu [image] (Parametri (Setup) GRAC-a)

U zavisnosti da li je Digitalnim topografskim ključem za znak predviđeno njegovo roriranje ono se nudi ili ne nudi.

Pikir

Pikir

Command: GPikir

Insertovanje pikira na pokazanu tačku (blok: PIKIR)

Prip

Znak pripadnosti

Command: Pripadnost

Insertovanje znaka pripadnosti na pokazano mesto na entitet LINE (blok: PRIP)

PonLin

Znak ponistenja linije

Command: PonLin

Insertovanje znaka poništenja linije na pokazano mesto na entitet LINE (blok: PONLIN)


Padne linije (škarpe)

Navigation: Topografija >

Padne linije (škarpe)

 Return to chapter overview

Padne linije (skarpe)

Command: Skarpa

Na pokazanu LINE, rotiranjem se, izabere strana insetrovanja, kretanjem kursora duž te linije i pritiskom na levi taster, bira se dužima insertovanja padnih lonija, nakon čega se pozicijom ponuđene linije bira dubina padnih linija. Ako je se u tački pokazane dubije pronađe entitet LINE, tada se dubine padnih linija crtaju do te pokazane linije iako ona nije paralelna sa početnom linijom crtanja škarpe.

Komandom [image] (Parametri (Setup) GRAC-a) definiše se razmak između padnih linija kao i razmera crtanja sa kojom se isti usklađuje.

Snaka insertovana grupa padnih linija je AutoCAD entitet Anonymous blocks.


Šrafiranje

Navigation: Topografija >

Šrafiranje

 Return to chapter overview

Srafiranje paralelno

Command: SrafirP

Ako se pokaže tačka unutar konture bliže nekoj LINE, detektovaće se i pokazati zatvorena kontura a na potvrdan odgovor da je detektovana kontura dobra, insetrovaće se šrafura paralelna toj liniji, razmaka između njih i udaljenja od konture definisanog komandom [image] (Parametri (Setup) GRAC-a)

Ako se pokaže tačka van konture bliže nekoj LINE, detektovaće se i pokazati obuhvatna zatvorena kontura

Srafiranje koso

Command: Srafirk

Ako se pokaže tačka unutar konture bliže nekoj LINE, detektovaće se i pokazati zatvorena kontura a na potvrdan odgovor da je detektovana kontura dobra, insetrovaće se šrafura koja je pod uglom od 45o na tu liniju, razmaka između njih i udaljenja od konture definisanog komandom [image] (Parametri (Setup) GRAC-a)

Ako se pokaže tačka van konture bliže nekoj LINE, detektovaće se i pokazati obuhvatna zatvorena kontura


Cepanje

Navigation: »No topics above this level«

Cepanje

 Return to chapter overview

Izdvajanje željene površine iz konture definisane entitetima LINE (bez obzira da li su one skrecene ili ne)

Deobnom linijim se konturne linije automatski "brejkuju" i skraćuju ako su one predhodno bile skraćene.

Ako se na pitanje "Pokazi BROJ parcele ili TACKU unutar/izvan konture:" pokaže

· Broj parcele (entitet block: BROJ) tada se vrši CEPANJE parcela kojom prilikom se uzima u obzir i "Administrativna" (površina iz operata). Ako ta površina nije uneta, otvara se mogućnist njenog unosa i ista se pridružuje entitetu broja padcele kao podatak i on se manifestuje u svim daljim operacijama sa tom parcelom
· Tačka van broja parcele, onda se jednostavno vrši deoba detektovane kontre.


Cepanje parcela

Navigation: Cepanje >

Cepanje parcela

 Return to chapter overview

Cepanje parcela PARALELNO

Command: CepaP

Iz zatvorene konture, eltitetima LINE, bez obzira dali su skracene ili ne, izdvaja se određena površina deobnom linijom koja je paralelna bilo kom, dvema tačkama, definisanim pravcem.

Zadata površina se izdvaja uvek sa desne strane deobne linije gledano u istom smeru u kome je i smer pokazane linije.

Novom ili novim deobnim linijama se prekidaju (brejkuju) konturne linije.

Cepanje parcele RADIJALNO

Command: CepaR

Iz zatvorene konture, eltitetima LINE, bez obzira dali su skracene ili ne, izdvaja se određena površina deobnom linijom koja je jednim svojim krajem fiksirana u nekoj tački na toj konturi.

Deobna linija se rotira oko pokazane fiksne tačke dok se sa pokazane strane te linije ne dobije zadata površina.

Novom ili novim deobnim linijama se prekidaju (brejkuju) konturne linije.

Cepaf

Cepanje parcele po FAKTIČKOM stanju

Command: CepaR

Priprema:

Unutar konture parcele upisuje se broj parcele nekom od ikona Brpar0 brparph Brparpk Brparck brparch .

Entitetima LINE nacrtati fakticku liniju deobe parcele.

Izvršavanje:

Pokazati broj parcele koja se deli. Ako broju parcele nije dodeljena površina parcele iz operata, biće zatraženo da to uradite.

Pokažite mesta upisa brojeva novih parcela.


Digitalni Model Terena (DMT)

Navigation: 3D Model >

Digitalni Model Terena (DMT)

 Return to chapter overview

Formiranje 3D modela TIN (Triangulated Irregular Network) za skup tačaka, podrazomeva formiranje 3DFACE AutoCad entiteta tj. 3D trouglova primenom "Delauney Triangulation" što jednostavnije rečeno podrazumeva da su trouglovi "što približniji jednakostraničnim", i da "opisana kružnica oko trougla triangulacije ne sadrži nijednu drugu tačku triangulacije"

3D model terena će se formiraće na osnovu detaljnih tačaka predstavljenih u crtežu blokom TACKA čiji je

1. Atribut IMTAC (ime tačke)
2. Atribut KOTAC (kota tačke)
3. Atribut OPTAC (opis tačke, ako ga ima)

U skup tačaka za formiranje 3D modela, biće uključene tačke iz svih vidljivih lejera i čiji je 2. Atribut KOTAC uključen (visible) i različit od 0 (nule)

Pojedinačno Uuključenje ili Isključenje tačke u 3D model može se vršiti komandom Izovant (NEucestvuje/Ucestvuje u DMT)

Grupno Uuključenje ili Isključenje tačaka u 3D model može se vršiti komandom Attvisibl (Pali/Gasi Atribut)

Ako se želi primena uslovljene triangulacije tj. da stranice 3D trouglova moraju biti zadate linije (a to su: gornja ili donja ivice škarpe, kanala, vododerina, potok, greben ...) tada je potrebno komandom [image] (Linije obavezne interpolacije) kreirati takve linije ili komandom Izobez (Povrsine bez izohipsa) obeležiti površine preko kojih se ne vrši interpolacija. Linije koje oivičavaju te površine su istovremeno linije obavezne interpolacije.

Ako se želi uraditi 3D model samo za deo tačaka potrebno je na neki način napraviti LWPOLYLINE konturu obuhvata 3D modela, u lejeru "3D-obuhvat-interpolacije"

Ako se želi formirati 3D model za sve aktuelne tačke tada se proces startuje komandom [image] (3D Triangulacija za DMT (Tin)) nakon čega se na zahtev da se pokaže kontura obuhvata, pritiskom na desni taster miša, može odustati od pokazivanja, čime se daje instrukcija da se 3D model radi za sve tačke. Na ovakav način formirani 3D medel je konveksna skupina 3D trouglova od kojih su neki suvišni i kvare 3D model a koje treba ručnim brisanjem odstraniti iz modela. To su uvek spoljni trouglovi sa dva veoma ošta i jednim veoma tupim uglom, koji se lako uočavaju.

Ako su u lejeru "3D-linije-obavezne-interpolacije" definisani entiteti LINE ili LWPOLYLINE tada će se osnovni 3D model automatski korigoti na te linije kao linije obavezne interpolacije.

Ako se linije, definisane u nekom drugom lejeru, žele proglasiti linijama obavezne interpolacije i 3D model korigovati na njih, upotrebiti komandu Struktri (3D Trouglovi na obavezne linije)

Dodavanje novih detaljnih tačaka u več formirani 3D model može se izvršiti komandom Trik (Lokalno tinovanje) tako što se najpre izbrišu oni 3D trouglovi u koje upadaju dodate tačke ili se pokaže LWPOLYLINE unutar koje se želi ponovno tinovanje.

Radi vernijeg prikaza DMT obavezno je, primarno formirane 3D trouglove, korigovati komandom Struktri (3D Trouglovi na obavezne linije) kojom se postiže da ih strukturne linije, ne seku

Ovako dobijeni 3D model služi za:

· iscrtavanje izohipsa
· računanje zapremina između dve situacije (između dva fajla)
· iscrtavanje podužnih i poprečnih profila


Interpolacija

Navigation: 3D Model > Digitalni Model Terena (DMT) >

Interpolacija

 Return to chapter overview

Ekvidistantna

Command: Interpol0

Insertovanje neimenovanih detaljnih tačaka interpolacijom između dve detaljne tačke na na kote ekvidistantne vrednosti

Vise kota na liniji

Command: Interpol1

Insertovanje neimenovanih detaljnih tačaka interpolacijom između dve detaljne tačke na željenom mestu između tih tačaka

Pojedinacno izmedju 2 tacke

Command: Interpol2

Insertovanje imenovane detaljne tačake interpolacijom između dve detaljne tačke na željenom mestu između tih tačaka


Priprema za DMT (Tin)

Navigation: 3D Model > Digitalni Model Terena (DMT) >

Priprema za DMT (Tin)

 Return to chapter overview

Unos/Edit vrednosti Ekvidistancije

Command: IzoEkvid

Unos ili editovanje vrednosti Ekvidistancije (visinskog razmaka između izohipsa)

Polilinija obuhvata DMT

Command: LWPobuhvat

Formiranje konture obuhvata 3D modela oko već formiranih 3DFACE trouglova

Obuhvat se formira u lejeru:

· "3D-obuhvat-interpolacije"

NEucestvuje/Ucestvuje u DMT

Command: Van3D

Pojedinačno Uključivanje i Isključivanje tacaka iz formiranja 3D model.

Tacka kojoj se vidi kota je ukljucena u formiranje 3D modela

Pažnja: Ovo se radi PRE formiranja 3D trouglova

Povrsine bez izohipsa

Command: KontIzo

Definisanje površina preko kojih se ne vrši interpolacija izohipsa. Linije koje čine te površine su istovremeno linije obavezne interpolacije

Tom prilikom se automatski formiraju lejeri:

· "3D-linije-obavezne-interpolacije

u koji su snesteni nivoformirani eltiteti LWPOLYLINE kontura tih povrsina
· "3D-povrsine-bez-izohipsa"

u koji su smesteni HATCH-ovi tih površina

Linije obavezne interpolacije

Command: LineIzo

Definisanje ostalih entiteta LINE i LWPOLYLINE, linijama obavezne interpolacije. To se postiže njihovim kopiranjem u lejer

· "3D-linije-obavezne-interpolacije"

Pomocna linija za ispis kota izohipsa

Command: LineBro

Iscrtavanje pomoćne LWPOLYLINE u lejeru:

· "3D-linija-brojeva-izohipsa"

u čijim će presecima sa 5-om izohipsom buti ispisane kote tih izohipsa


3D triangulacija

Navigation: 3D Model > Digitalni Model Terena (DMT) >

3D triangulacija

 Return to chapter overview

3D Triangulacija za DMT (Tin

Command: Triangulate

Formiranje mreže 3D trouglova (3DFACE) primenom "Delauney Triangulation"

Ako se na zahtev: "Pokazi LWPOLYLINE konturu OBUHVATA:" pokaže zatvorena LWPOLYLINE u bilo kom lejeru

tada će se taj entitet prebaciti u lejer:

· "3D-obuhvat-interpolacije"

formiraće se 3D trouglovi samo u tom prostoru.

(U stvari formiaju se 3D trouglovi za ceo crtež pa se onda odbace svi oni čija težišta padaju van konture obuhvata)

Ako se na taj zahtev odgovori pritiskom na DESNI taster miša formiraje se 3D model (mreža trouglova) za ceo crtež.

Struktri

Lokalno tinovanje

Command: StrukTriang

Ako se iz nekog razloga u situaciju, dodaju nove detaljne tačke ili se izbriše deo 3D trouglova, ovom komandom se taj prostor lokalno tinuje tj. popunjava novim 3D trouglovima.

Pažnja: Prostor koji se popunjava novim 3D trouglovima, mora da bude opkoljen već formiranim 3D trouglovima ili da bude omeđen LWPOLYLINE entitetom, koja u svojim temenima ima detaljne tačke sa kotama ili temena 3D trouglova.

Struktri

3D Trouglovi na obavezne linije

Command: StrukTriang

Korigovanje 3D mreže trouglova na linije obavezne interpolacije. Ovime se postiže da se linije obavezne interpolacije (strukturne linije) unek nađu na neloj od stranica 3D trouglova

Ako se na zahtev: "Pokazi uzorak LINE/LWPOLYLINE linije obavezne interpolacije:" pokaže kao uzorak neki od entiteta LINE ili LWPOLYLINE tada će svi entiteti sa tim svojstvima biti smatrane linijama obavezne interpolacije i trouglovi će biti korigovani tako da svaka od tih linija bude obavezno jedna od stranica nekog od trouglova:

Ako se na taj zahtev odgovori pritiskom na DESNI taster miša tada će sve LINE i LWPOLYLINE iz lejera:

· "3D-linije-obavezne-interpolacije"

biti smatrane linijama obavezne interpolacije.

Korigovanje 3D trouglova pojedinačno

Command: TdtriLW

Ako je formiran 3D model terena pokazujući neku od zajedničkih stranica 3D trougla (3DFACE) touglovi će biti prekomponovani.

Ako je 3D model interpolovan LINE, neglačanim LWPOLILINE izohipsama i one će biti preinterpolovane.

Pažnja: U ovoj verziji programa nije moguće, korigovanjem trouglova, korigovati SPLINE ili konačne LWPOLYLINE izohipse


Izohipse

Navigation: 3D Model >

Izohipse

 Return to chapter overview

Izohipse se dobijaju nakon formiranja 3D modela u nekoliko koraka. Najpre se komandom

(Interpolacija Trouglova na LINE izohipse) svi trouglovi interpoluju na LINE unutar svakog trougla u lejeru "3D-izohipse" a zatim komandom
(Glacanje izohipsa (LINE u LWPOLYLINE)) predhodno formirane LINE izohipsa istih kota spajaju u neglačane LWPOLYLINE izohipse

Ako se na pitanje "Glacate IZOHIPSE (lwpolyline u SPLINE)?" pozitivnoodgovori dobeće se SPLINE izohipse u protivnom proces se prekida ali se može nastaviti komandom Ilw2sp (Glacanje izohipsa (LWPOLYLINE u SPLINE))

Ako se na pitanje "Glacate IZOHIPSE (spline u LWPOLYLINE)?" odgovori pozitivno dobieće se optivizovane LWPOLYLINE u protivnom proces se prekida ali se može nastaviti komandom Isp2lw (Pretvaranje izohipsa (SPLINE u LWPOLYLINE))

Ako se pre startovanja završne faze formiranja izohipsa tj. Glacate IZOHIPSE (spline u LWPOLYLINE), komandom [image] (Pomocna linija za ispis kota izohipsa) kreiraju polmoćne linije u njihovim presecima sa 5. om izohipsom biće ispisane kote. Komandom Izonumer (Pojedinacno upisivanje kote izohipse) na željenim mestu, na 5. izohipsi, upisije se njena kota.

Ako su komandom [image] (Povrsine bez izohipsa) definisane površine bez izohipsi, formiraji se takođe izohipse i u tom prostoru ali u lejeru "3D-izohipse-bez"


Izohipse

Navigation: 3D Model > Izohipse >

Izohipse

 Return to chapter overview

Interpolacija Trouglova na LINE izohipse

Command: Interpln

Interpolovanje 3D trouglova u izohipse LINE u lejeru "3D-izohipse".

Ako je 3D trougao u prostoru bez izohipsa tj. unutar zatvorene LWPOLYLINE u lejeru "3D-povrsine-bez-izohipsa"

tada se izohipse LINE smeštaju u lejer "3D-izohipse-bez"

Glacanje izohipsa (LINE u LWPOLYLINE)

Command: Line2LWP

Spajanje linija interpolovanih u 3D izohipse u LWPOLYLINE

u lejerima "3D-izohipse" i "3D-izohipse-bez"

Ilw2sp

Glacanje izohipsa (LWPOLYLINE u SPLINE)

Command: Lwpglac

Glačenje (zaobljavanje) izohipsa LWPOLYLINE njihovim pretvaranjem u SPLINE

u lejerima "3D-izohipse" i "3D-izohipse-bez"

Isp2lw

Pretvaranje izohipsa (SPLINE u LWPOLYLINE)

Command: Spltolwp

Konvertovanje izohipsa SPLINE u optimizovani entitet LWPOLYLINE uz predhodno definisani kroz Setgrac Setup AcadGRAC-a

· "Segment seckanja [m]"

dužina na koju se secka (racunaju koordinate) entiteta SPLINE
· "Opseg peglanja [m]:"

koliko tacka može da bude udaljena od pravca u LWPOLYLINE a da se smatra da je na pravcu

u lejerima "3D-izohipse" i "3D-izohipse-bez"

Izonumer

Broj izohipse

Command: BrIzohipse

Ako se pokaže pomoćna linija iz lejera "3D-linija-brojeva-izohipsa" tada se insertuju u preseku tih linija i 5. ili 4. izohipsi insertuju nominalne vrednosti tih izohipsi

Ako se pokaže sama 5. ili 4. izohipsa iz lejera "3D-izohipsa" tada se u toj tački na izohipsu insertuje njena nominalna vrednost


Profili/Zapremine

Navigation: 3D Model >

Profili/Zapremine

 Return to chapter overview

PROFILI

Podužni i poprečni profili se mogu raditi na situacijama na kojima je predhodno urađena 3D triangulacija tj. fprmirani 3D trouglovi ili ako je situacija "spojena" entitetima LINE o čemu se izjašnjava na početku izrade profila.

Podužni profil podrazumeva da je njegova osovina kontinuirana LWPOLYLINE entitet koja u slučaju postojanja 3D troujlova ne mora da se lomi u tačkama sa kotama u protivnom mora da prolazi kroz tačke.

Poprečni profili su uvek upravni na njihovu podužnu osovinu (podužni profil) dok je u prelomnim tačkama podužne osovine u simetrali.

Pojas LEVO i pojas DESNO poprečnog profila je uvek u smeru rasta stacionaže (a tako se i iscrtavaju).

Profili se mogu iscrtavati u prostoru Model-a i Layout-a uz mogućnost izjašnjavanja o dužinskoj i visinskoj razmeti iscrtavanja.

ZAPREMINE

Zapremine se mogu raditi na situacijama na kojima je predhodno urađena 3D triangulacija tj. fprmirani 3D trouglovi ili ako je situacija "spojena" entitetima LINE o čemu se izjašnjava na početku.

STACIONIRANJE TRASE

Automatsko postavljanje osovina poprečnih profila

POSTUPAK

Da bi se mogli dobiti podužni i poprečni profili potrebno je najpre:

- Na situaciji formirati 3D model terena u vidu 3D trouglava (3DFACE entiteta) ili za izduženu situaciju spojiti situacija strukturnim linijama (podužne ivice puta, nasipa, kanala, škarpi i ostale linije situacije)

- Nacrtati entitetom LWPOLYLINE podužnu osovinu trase (poprečnih profila)

- Ručno nacrtati entitetom LINE osovine poprečnih profila, na željenim mestila ili

- Automatski komandom Profili (Podužni i poprečni profili) izvršiti opciju Stacioniranje trase nakon čega se postave i numerišu linije poprečnih profila.

ponovo komandom Profili (Podužni i poprečni profili) izvršiti opciju Podužni i poprečni profili nakon čega se u posebnim Layout-ima formiraju profili


Profili

Navigation: 3D Model > Profili/Zapremine >

Profili

 Return to chapter overview

Poduzni i poprecni profili

Command: CrtPr

Po startovanju komande pojavljuje se Dijalog Box u kome se izjašnjava za jedan od dva tipa situacije nad kojima se rade profili ili automatsko postavljanje osovina poprečnih profila

Kroz Dijalog Box se definišu parametri iscrtavanja podužnog i poprenih profila

Pažnja: Osovina podužnog profila mora da je jedna LWPOLYLINE a Osovine poprečnih profila mora da su LINE

· TIN-ovana (3DFACE trouglovi)

Podrazumeva se da je nad situacijom predhodno urađena 3D triangulacija tj. fprmirani 3D trouglovi i

izvršeno Stacioniranje trase

· Izduzena (kanal, put, nasip ...)

Za izdužene situacije koje su "spojene" entitetima LINE od tačke do tačke.

Profili se dobijaju automatskom interpolacijom linija koje na svoja oba kraja imaju kote (block TACKA sa kotom)

· Poprecni Profili po trasi dve situacije

Iscrtavanje poprečnih profila za dve situacije na jednom mestu

Po startovanju ove komande potrevno je odabrati fajl sa drugom situacijom čiji se poprečni profili žele.

Na zahtev: Pokazi (LWPOLYLINE) uzorak obuhvata zapremine: pokazati odgovarajući entitet ili desnim tasterom miša odustati od toga.

Zatim pokazati (LWPOLYLINE) podužne ose poprečnih profila a zatim uzorak (LINE) neke od osovina poprečnih profila.

Druga Situacija se insertuje u novi Layout pod imenom fajla druge situacije.

U novo kreiranom Layoutu Poprecni-profili-DVA-stanja, pojaviće se poprečni procfili obe situacije gde je linija terena situacije iz Modela u plavoj boji.

Ako je pokazana (LWPOLYLINE) kontura obuhvata tada će se u poprečnom preseku pojavi i vertikalna linija koja predstavlja presek profila sa konturom obuhvata.

· Stacioniranje trase

Automatsko postavljanje osovina poprečnih profila, definisanje posaja profila, njihovo numerisanje i zadavanje vrednosti početne stacionaže

Ako je trasa već stacionirana potrebno je obrisati sve nepotrebne osovine poprečnih profila kao i sve brojeve profila

Na pitanje: Pokazi (LWPOLYLINE) TRASU profila: pokazati LWPOLYLINE podužnu osovinu poprečnih profila

Odgovoriti na pitanje: Smer poduzne trase (lwpolyline) je DOBAR:?

Na pitanje: Pokazi liniju POPRECNOG profila: pokazati kao uzorak neku od LINE osovinu poprečnih profila ili desnim tasterom miša dati instrukciju da se želi stacioniranje uz sledeći Dijalog Box:

Ako se izvrši korigovanje tj. izbacivanje ili umetanje nekih poprečnih profila, da bi se izvršila prenumeracija poprečnih profila, mora da se ponovi ova komanda


Zapremine

Navigation: 3D Model > Profili/Zapremine >

Zapremine

 Return to chapter overview

Zapremina

Command: Zaprem

Dijalog Box za izjašnjavanje o tipu i načinu računanju zapremine

· Zapremina izmedju dve 3DFACE situacije

Računanje zapremine između dve 3DFACE situacije iz dva različita fajla

Da bi se zapremina uradila potrebno je da se zatvorenom LWPOLYLINE definiše kontura prostora zapremine i kroz Dialog Box odabere fajla sa situacijom u odnosu na koju se računa zapremina.Pri obradi prikaziju se međurezultati za obe situacijeu vidu zapremine od kote 0.00 do do 3D modela unutar pokazane LWPOLYLINE i na kraju pozitivna ili negativna vrednost zapremine što predstavlja prvog i drugog međurezultata.

Potvrda da su međurezultati dobri tj. da je površina svih delova 3D trouglova i površina prostora interpolacije ogleda se u veličini dP

· Zapremina 3DFACE do horizontalne ravni na koti ...

Računanje zapremine 3DFACE situacije do neke horizontalne ravni unutar pokazane LWPOLYLINE koja definiše kontura prostora zapremine

Rezultat je prikazan u AutoCAD Message Box-u.

· Zapremina iz Poprecnih Profili po trasi izmedju dve situacije

Koristeći fajl "ZapreminaPP.dwg" (ili onako kako je preimenovan) koji je nastao posle komande Poprecni Profili po trasi dve situacije a u kome su iscrtani poprečni profili za dve situacije na jednom mestu i koji je obradjen tj. formiranje zarvorene konture po svim profilima, računana se zapremina izmiđu dve situacije po profilima i formira izveštaj kao Excel dokument.

Iz Po startovanju ove komande potrebno je selektovati fajl sa situacijom

· Izvuci izohipsu na koti .....

Na situaciji na kojoj su formirani 3D trouglovi, izljači se neglačana LWPOLYLINE izohipsa zadate kote.


Stampanje/Okvir

Navigation: »No topics above this level«

Stampanje/Okvir

 Return to chapter overview

Štampanje ili bolje rečeno priprema crteža za štampanje, podrazumenva prvenstveno formiranje Layouta i Viewporta u prostoru papira, onih dimenzija koliki želimo da nam bude crtež sa pogledom na onaj deo Modela koji želimo da štampamo.

Pogled na Model definisan je faktorom skaliranja u Viewportu i on zavisi od razmere u kojoj želimo da nam crtež bude odštampan.

Dole kreiranim komandama taj posao kao i formiranje koordinatnog opisa i insertovanje desimetarske mreže u prostoru papira (ili Modela) je njima znatno olakšan i pojednostavljen.

Po izvršenoj pripremi, štampanje se obavlja iz Layouta, (pritiskon iznad željenog Layouta desnim tasterom muša) komandom Plot, gde se zatim bira uređaj za štampanje ali Plot scale je uvek 1:1


Štampanje

Navigation: Stampanje/Okvir >

Štampanje

 Return to chapter overview

Lou

Okvir i priprema stampe

Command:Okvir

Definisanje dimenzija OKVIRA u mm i njegovo insertovanje u odgovarajućoj Razmeri.

Insertovanje Template A3, A4, A0, položeni ili uspravno i drugih u prostoru Model-a ili Layout-a sa nanošenjem i opisom desimetarske mreže

Insertovanje Detaljnih listova u Layout-u sa nanošenjem i opisom desimetarske mreže uz predhodno izjašnjavanje o demenziji lista:

Insertovanje Detaljnih skica u Layout-u sa nanošenjem i opisom desimetarske mreže uz izjašnjavanje:

Ako je markirana Lokacija okvira u Modelu i insertovanje Desimetarske mreže tada se samo u Modelu insertuje mreža desimetarskih krstića za ceo prostor crteža a zatim i zadati okvir u skladu sa aktuelnom razmerom na željenu poziciju.


Layout

Navigation: Stampanje/Okvir >

Layout

 Return to chapter overview

Vprazmera

Razmera stampanja

Command: VPRaz

Definisanje dimenzija OKVIRA u mm i njegovo insertovanje u odgovarajućoj Razmeri.

Vpcentar

Novi centar pogleda

Command: VPRcen

Definisanje novog centra pogleda tj, pokazana tačka na crtežu je u centru prostora crtanja.

Vpotvori

Odkljucavanje POGLEDA

Command: VPON1

Odključavanje pogleda za promene

Vpzatvori

Zakljucavanje pogleda

Command: VPON0

Zaključavanje pogleda da ne menja razmeru

Opiskor

Koordinate opisa Layouta

Command: OpisKor

Insertovanje koordinatnog opisa i desimetarske mreže u prostoru papira za aktualni pogled


EXCEL prilozi

Navigation: »No topics above this level«

EXCEL prilozi

 Return to chapter overview

Vidi Excel dokumente u folderu programa


DODATAK (WW)

Navigation: »No topics above this level«

DODATAK (WW)

 Return to chapter overview

Svi ostali programi i komande koje, za sada, nisu našle svoje mesto u Toolbar-ovima u vidu ikona mogu se koristiti startovanjem komandom WW sa komandne linije kojom prilikom se dobija Lista sa spiskom komandi koje se nalaze u tekstualnom fajlu 0Lispovi.txt

Brisanje SVIH duplih entiteta u DWG-u | CHKDUP
Export Tacaka i Linija DWG-a i za GRAC pod DOS-om | DWG2GRAC
Spajanje vise fajlova (*.YXZ i *.VEZ) iz GRACa u jedan DWG | YXZVEZ2DWG
Prevodjenje ranijih ili tudjih DWG-a u AcadGRAC | BILOSTA2GRAC
Prebacivanje crteza u Apsolutni koordinatni sistem | UGK
Blok TACKA od TEXT imena i TEXT kote (preko koordinate upisa texta) | TEXT2TAC
Blok TACKA od TEXT imena i TEXT kote (preko najblizeg entiteta texta) | TEXT2TAC1
Blok TACKA od BLOKa imena i BLOKa kote | BLOK2TAC
Blok TACKA od GRUPE (pikir, ime TEXT i kota TEXT) | GRUPA2TAC
Blok TACKA 3D point sa numerisanjem | UGRAC
Blok TACKA od bloka sa vise atributa | BLOKAT2TAC
Kreiranje bloka TACKA od drugih entiteta | SETACKA
Prevodjenje broja i kote tacke kao TEXT-a u blok TACKA | TEXT2TACW
Kreiranje bloka TACKA od posebnih blokova IMENA i KOTE | UGRAC10
Reinsertovanje bloka TACKA | REINSTAC
Zaokruzivanje koordinata entitera | ZAOKORD
Produzenje skracenih entiteta LINE koje na krajevina nemaju pikir | TRIMLIN
Produzenje skracenih entiteta LINE do pikira | LINEPRODP
Produzenje skracenih entiteta ARC do pikira | ARCPRODP
Predefinisanje lokacije rastera upotrebljenih u DWG-u | RERAST
Vracanje Scale faktora blokova na 1.0 | SKAL10
Brisanje DUPLIH eltiteta LINE | DELDUPLINE
Brisanje duplo INSERTovanih entiteta | DELDUPINS
Brisanje svih MALIH eltiteta LINE | BRISISVEMALE
Brisanje DALEKIH entiteta | BRISIDALEKE
Selektiranje preko uzoraka za komandu WBL | WBLS
Pokupi entitete po LWPOLYLINE | POKUPIPOLW
Prekidanje snih LINE | BREKLINE
Prekidanje Selektovanih/Svih entiteta LINE bolkom TACKA | GRACBREJK
Debljine svake 5 izohipse | SVAKA5IZO
Ispisivanje podataka PPROFILA u tabelu | SPUSTI
Insetrovanje tacaka u linije poprecnih profila | GPOPPRESEK
Koordinate Desimetarskig krstica u Modelu | KORDESMREZE
Editovanje trouglova 3DModela | EDITRIANG
Tacka sa dve kote od dve tacke na istom mestu | SELDRUGAKOTA
Tacka sa dve kote od tacaka na selektiranim LWPOLYLINE | LWDRUGAKOTA
Vracanje originalnih imena tacaka posle prenumeracije | ORIGIMTAC
Insertovanje bloka TACKA na krajevima selektiranih entiteta LINE | TACNALIN
Smestanje SVIH rastera DWG-a u bazu za ponovni ucitavanje | TABRASVE
Promena broja decimala kota tacaka | KOTEDEC
Preseljava Atribite SVIH tacaka u jedan lejer i prevodi u ByBlock | GRACTA
Modifikuje blok TACKA tako da su Atributi u posebnim lejerima | TACKAGRAC
Ispisivanje HORIZONTALNIH duzina frontova za selektirane entitete LINE | SFRON
Ispisivanje PRIBLIZNIH Horizontalnih duzina frontova LINE (po uzorku) | EFRON
Ispisivanje PRIBLIZNIH KOSIH duzina frontova LINE (po uzorku) | KFRONT
Ispisivanje Tacnih KOSIH duzina frontova LINE (po uzorku) | FRONK
Premestanje texta FRONTA iznad i ispod linije | OFRON
Insertivane blokova sa drugih lokacija preko slajdova | SLIDE
Transformacija crteza u SUSEDNU ZONU | USUSZONU
Dobijanje GEOGRAFSKIH koordinata | FILA
Koordinate u susednoj ZONI | SUZO
Prevodjenje AcadGrac DWGa za SURVEY programski paket | TOJAN
Prevodjenje 3DFACE trouglova u entitete LINE | LNOD3DF
Kota tacke na bilo kom mestu u 3D modelu (3DFACE) | KOTA3D
Spajanje LINE, LWPOLYLINE i ARC u entitete LWPOLYLINE | L2WW
Promena smera entiteta LWPOLYLINE | REVERSELW